summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-09-22 12:54:04 -0400
committeracxz2019-09-22 12:54:04 -0400
commitac1ec874ebef216469eb422920200ac70dc11354 (patch)
treed9e6567ab522ec5a2279f7f80b4a80697b1fdc2b /PKGBUILD
parent3ca307510b5c2db8d8a69adc2c5a66ba7abe0b0b (diff)
downloadaur-ac1ec874ebef216469eb422920200ac70dc11354.tar.gz
Use python 3 to build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 30 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f634034c0960..6d5874f82f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,39 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
-pkgdesc="ROS - Small lib to transform sensor_msgs with tf."
-url='https://www.wiki.ros.org/tf2_ros'
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
+pkgdesc="ROS - Small lib to transform sensor_msgs with tf. Most notably,
+PointCloud2"
+url='https://wiki.ros.org/tf2_sensor_msgs'
pkgname='ros-melodic-tf2-sensor-msgs'
pkgver='0.6.5'
-_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
-ros_makedepends=(ros-melodic-catkin
- ros-melodic-tf2-ros
- ros-melodic-tf2
- ros-melodic-sensor-msgs
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-cmake-modules
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ 'eigen3'
${ros_makedepends[@]}
- eigen3)
+)
-ros_depends=(ros-melodic-python-orocos-kdl
- ros-melodic-tf2-ros
- ros-melodic-tf2
+ros_depends=(
ros-melodic-sensor-msgs
- ros-melodic-rospy)
-depends=(${ros_depends[@]}
- eigen3)
+ ros-melodic-tf2
+ ros-melodic-tf2-ros
+ ros-melodic-python-orocos-kdl
+ ros-melodic-rospy
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/tf2_sensor_msgs/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+depends=(
+ ${ros_depends[@]}
+)
-# Tarball version (faster download)
_dir="geometry2-${pkgver}/tf2_sensor_msgs"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/geometry2/archive/${pkgver}.tar.gz")
sha256sums=('9a1268621518fc22afd7b12ef1cf30e6901a57b054535924d1d74fd5d267773a')
@@ -48,17 +48,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}