summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-08 15:04:33 +0200
committerGonçalo Camelo Neves Pereira2018-09-08 15:04:33 +0200
commit4d730d22c80f76fc863d3aeecead503b86e85601 (patch)
tree58585ac52b0f68d7ff8b0b2309fa907ae75c8611 /PKGBUILD
parentc9be0d054ca90fdb3bee3eb1abf22d2f1f40c262 (diff)
downloadaur-4d730d22c80f76fc863d3aeecead503b86e85601.tar.gz
Update!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD123
1 files changed, 69 insertions, 54 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07e10f225657..34406a84405f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - Theora_image_transport provides a plugin to image_transport for transparently sending an image stream encoded with the Theora codec."
url='http://www.ros.org/wiki/image_transport_plugins'
@@ -10,67 +10,82 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-dynamic-reconfigure
- ros-melodic-std-msgs
- ros-melodic-catkin
- ros-melodic-pluginlib
- ros-melodic-rosbag
- ros-melodic-cv-bridge
- ros-melodic-image-transport
- ros-melodic-message-generation)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- libogg
- libtheora)
+ros_makedepends=(
+ ros-melodic-pluginlib
+ ros-melodic-message-generation
+ ros-melodic-catkin
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-rosbag
+ ros-melodic-cv-bridge
+ ros-melodic-image-transport
+ ros-melodic-std-msgs
+)
-ros_depends=(ros-melodic-dynamic-reconfigure
- ros-melodic-std-msgs
- ros-melodic-message-runtime
- ros-melodic-pluginlib
- ros-melodic-rosbag
- ros-melodic-cv-bridge
- ros-melodic-image-transport)
-depends=(${ros_depends[@]}
- libogg
- libtheora)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ libtheora
+ libogg
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/theora_image_transport/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/image_transport_plugins-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-pluginlib
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-rosbag
+ ros-melodic-cv-bridge
+ ros-melodic-image-transport
+ ros-melodic-std-msgs
+)
-# Tarball version (faster download)
-_dir="image_transport_plugins-release-release-melodic-theora_image_transport-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/image_transport_plugins-release/archive/release/melodic/theora_image_transport/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('03701fa45f64b4642eb8b7720662363bb10c4f20e32da2783c595258fc3eaced')
+depends=(
+ ${ros_depends[@]}
+ libtheora
+ libogg
+)
+
+_dir=${pkgname}
+source=("${_dir}"::"git+https://github.com/ros-gbp/image_transport_plugins-release.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${srcdir}/${_dir}
+ git checkout upstream
+ _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
+
+ if [ -d ${_pkgname} ]; then
+ git subtree split -P ${_pkgname} --branch ${_pkgname}
+ git checkout ${_pkgname}
+ fi
+}
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}