summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:40:11 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:40:11 +0200
commit3ec162acb33b54b0deb18af3ccc7ce6e17936b49 (patch)
tree91c8fd5beb6ba0f1cd32b52af830698b5d6ecc99 /PKGBUILD
parent570aba32588f85259b449ab14bbaade05224054c (diff)
downloadaur-3ec162acb33b54b0deb18af3ccc7ce6e17936b49.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD115
1 files changed, 50 insertions, 65 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9433c01b47e1..f2b4a1013bee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - turtle_tf2 demonstrates how to write a tf2 broadcaster and listener with the turtlesim."
url='http://www.ros.org/'
@@ -10,78 +10,63 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-turtlesim
- ros-melodic-catkin
- ros-melodic-tf2-ros
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-tf2
- ros-melodic-std-msgs
-)
+ros_makedepends=(ros-melodic-std-msgs
+ ros-melodic-roscpp
+ ros-melodic-turtlesim
+ ros-melodic-tf2-ros
+ ros-melodic-geometry-msgs
+ ros-melodic-catkin
+ ros-melodic-tf2
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
-)
+ros_depends=(ros-melodic-std-msgs
+ ros-melodic-roscpp
+ ros-melodic-turtlesim
+ ros-melodic-tf2-ros
+ ros-melodic-geometry-msgs
+ ros-melodic-tf2
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
-ros_depends=(
- ros-melodic-turtlesim
- ros-melodic-tf2-ros
- ros-melodic-geometry-msgs
- ros-melodic-rospy
- ros-melodic-roscpp
- ros-melodic-tf2
- ros-melodic-std-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/turtle_tf2/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry_tutorials-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/geometry_tutorials-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="geometry_tutorials-release-release-melodic-turtle_tf2-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry_tutorials-release/archive/release/melodic/turtle_tf2/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('898be65b26bacc4c8ec117c9696b0506f18c33cce83c507442c3b4b239c64ada')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}