summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:35:36 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:35:36 +0100
commitec2795bf231ac7a93707ec075e05c5ee4f6a1772 (patch)
tree73ca6fe0cd162cb7612904cec3b163c2a9b53cb0 /PKGBUILD
parent5b8134614ba1fa4aeecd045d7f884c1db1079e38 (diff)
downloadaur-ec2795bf231ac7a93707ec075e05c5ee4f6a1772.tar.gz
New Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD82
1 files changed, 43 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4348921294df..add6cbb7a5b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - Python implementation of bond, a mechanism for checking when another process has terminated."
url='http://www.ros.org/wiki/bondpy'
@@ -10,55 +10,59 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-bond
- ros-melodic-smclib
- ros-melodic-catkin
- ros-melodic-rospy)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-smclib
+ ros-melodic-rospy
+ ros-melodic-bond
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-smclib
- ros-melodic-rospy)
-depends=(${ros_depends[@]}
- util-linux)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/bondpy/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/bond_core-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-smclib
+ ros-melodic-rospy
+)
+
+depends=(
+ ${ros_depends[@]}
+ util-linux
+)
-# Tarball version (faster download)
_dir="bond_core-release-release-melodic-bondpy-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/bond_core-release/archive/release/melodic/bondpy/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('c7dde4bdb17c65092192cf7f2b28294b6271f6d19cf3778a90106b74f0750781')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}