summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Hendy2019-10-12 19:02:21 -0500
committerGitHub2019-10-12 19:02:21 -0500
commit3f1b17b8b1a1f660270b87f79705e10f509d14e8 (patch)
tree84f8a7ed1c40a498a872afed65e91d7ebc51637d /PKGBUILD
parent20c85bc6916f4fa61609e9857edee3fd708eca9c (diff)
parent4dd10c01a926ad62267d8f94b55f6a0e40cba16f (diff)
downloadaur-3f1b17b8b1a1f660270b87f79705e10f509d14e8.tar.gz
Merge pull request #1 from acxz/boost-fix
patch boost issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4470b3b0bdcb..9488038edc14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,8 @@ url='https://wiki.ros.org/camera_calibration_parsers'
pkgname='ros-melodic-camera-calibration-parsers'
pkgver='1.11.13'
-_pkgver_patch=0
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -40,8 +39,15 @@ depends=(
)
_dir="image_common-${pkgver}/camera_calibration_parsers"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_common/archive/${pkgver}.tar.gz")
-sha256sums=('32a2e07724dec6eaaace21eae006274436d70d40bfe205249438570275c43cac')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-perception/image_common/archive/${pkgver}.tar.gz"
+ "boost-fix.patch")
+sha256sums=('32a2e07724dec6eaaace21eae006274436d70d40bfe205249438570275c43cac'
+ '85b506e095b95e6382b816625e798444c83e77f52eef8c98ed0182ef59d326d4')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -uN CMakeLists.txt ../../../boost-fix.patch || return 1
+}
build() {
# Use ROS environment variables.