summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormajor2020-01-08 17:56:08 +0000
committermajor2020-01-08 17:56:08 +0000
commitfe3d8a2a79f0d47db80ce51ec4e9f9ca24c31766 (patch)
tree871a4e35a84d4a49053429ff546a29bb4dbdc26f /PKGBUILD
downloadaur-fe3d8a2a79f0d47db80ce51ec4e9f9ca24c31766.tar.gz
initial commit with adjusted kinetic package (changes python2 to python3, kinetic to melodic)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adc86b474c9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - octomap_ros provides conversion functions between ROS and OctoMaps native types."
+url='http://ros.org/wiki/octomap_ros'
+
+pkgname='ros-melodic-octomap-ros'
+pkgver='0.4.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-octomap
+ ros-melodic-sensor-msgs
+ ros-melodic-octomap-msgs
+ ros-melodic-tf
+ ros-melodic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-octomap
+ ros-melodic-tf
+ ros-melodic-octomap-msgs
+ ros-melodic-sensor-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/octomap_ros/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/octomap_ros-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="octomap_ros-release-release-melodic-octomap_ros-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/octomap_ros-release/archive/release/melodic/octomap_ros/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('50dca555a5c7883b74068ae676db17671fa15da854f2985ed4999feff70089fd')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=-python3.8 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}