summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjwhendy2019-09-15 14:55:33 -0500
committerjwhendy2019-09-30 18:02:29 -0500
commit3c05d5d07a356ada347efe9c7ffa31827f4cdb64 (patch)
tree9b4d1c41d947837095b23904dc16a2f032daa011 /PKGBUILD
parent58745ec73daffcb3885a1e5cf047646e59630ec0 (diff)
downloadaur-3c05d5d07a356ada347efe9c7ffa31827f4cdb64.tar.gz
updated _dir, sources, and shasums; updated to python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3bde1269f399..9f40769772d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,7 @@ pkgdesc="ROS - Launch files to start the openni2_camera drivers using rgbd_launc
url='https://wiki.ros.org/openni2_launch'
pkgname='ros-melodic-openni2-launch'
-pkgver='0.2.3'
-_pkgver_patch=0
+pkgver='0.4.2'
arch=('any')
pkgrel=1
license=('BSD')
@@ -29,9 +28,9 @@ depends=(${ros_depends[@]})
# sha256sums=('SKIP')
# Tarball version (faster download)
-_dir="openni2_camera-release-release-melodic-openni2_launch"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/openni2_camera-release/archive/release/melodic/openni2_launch/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('eb18d74666fdb8d15f07220bbfcb7d5b47fda3a464c97ad51247667e88390a42')
+_dir="openni2_camera-${pkgver}/openni2_launch"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-drivers/openni2_camera/archive/${pkgver}.tar.gz")
+sha256sums=('98df75bef6d8865eab33ebeaec6b3bd098ca249b18c0e0459221483d51b0d2ca')
build() {
# Use ROS environment variables
@@ -43,17 +42,17 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
- -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
- -DPYTHON_BASENAME=-python2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7.so \
+ -DPYTHON_BASENAME=.cpython37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}