summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-06-27 22:37:51 -0400
committeracxz2019-06-27 22:37:51 -0400
commit997cc46f3f4fa130ea4fe1cab1c415066a630d59 (patch)
tree120b10cf58406b364bd2ab5ffdb4c786333eae98 /PKGBUILD
parent234e4579a17497178b2834d9ab103d882087bbb7 (diff)
downloadaur-997cc46f3f4fa130ea4fe1cab1c415066a630d59.tar.gz
build fix for missing QT env variable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1d2095288f4..97b19c51bae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ url='http://ros.org/wiki/qt_gui_cpp'
pkgname='ros-melodic-qt-gui-cpp'
pkgver='0.3.11'
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(
@@ -61,7 +61,14 @@ build() {
-DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
-DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
+
+ make || {
+ # Replace $$[QT_INSTALL_LIBS] with hardcoded /usr/lib/ for proper linking
+ # Relevant issue:
+ # https://github.com/ros-melodic-arch/ros-melodic-qt-gui-cpp/issues/4
+ sed -i 's/$$\[QT_INSTALL_LIBS\]/\/usr\/lib/' ${srcdir}/build/sip/qt_gui_cpp_sip/Makefile
make
+ }
}
package() {