summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-10 23:40:47 +0200
committerHermann von Kleist2020-05-10 23:40:47 +0200
commit986fc87894e961b8e677b232668a61daac27dd97 (patch)
tree2aba7df341c1e8dfdab8b580a18f821eb30d86f2 /PKGBUILD
parentedf23e7e930a112a6050ba943f609537e9a7c114 (diff)
downloadaur-986fc87894e961b8e677b232668a61daac27dd97.tar.gz
Update to 1.0.1 and noetic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 969dcc7d729e..89a6c65c15df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgdesc="ROS - This empty package allows to export rosbag migration rule files without depending on rosbag."
url='https://wiki.ros.org/rosbag_migration_rule'
-pkgname='ros-melodic-rosbag-migration-rule'
-pkgver='1.0.0'
+pkgname='ros-noetic-rosbag-migration-rule'
+pkgver='1.0.1'
arch=('any')
-pkgrel=2
+pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-melodic-catkin
+ ros-noetic-catkin
)
makedepends=(
@@ -28,29 +28,23 @@ depends=(
_dir="rosbag_migration_rule-${pkgver}"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/rosbag_migration_rule/archive/${pkgver}.tar.gz")
-sha256sums=('3943772fda87d82b84b0209d4da2e266872740b62f10447a0ad21b881edd20a2')
+sha256sums=('d92b7ae873835b084595538e547b19dbb7a2fc76f503bb24deefebc87eae9407')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}