summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-09-28 21:59:01 -0400
committeracxz2019-09-28 21:59:01 -0400
commit2b93d4dbc6cd444e375f8d58266e22f8dff8e0c9 (patch)
tree610dd0284bc7e6e45451b9320b9efc9490dff7b8 /PKGBUILD
downloadaur-2b93d4dbc6cd444e375f8d58266e22f8dff8e0c9.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD76
1 files changed, 76 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d789abcec348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+pkgdesc="ROS - The core rosbridge package, repsonsible for interpreting JSON and
+performing the appropriate ROS action, like subscribe, publish, call service,
+and interact with params."
+url='https://wiki.ros.org/rosbridge_library'
+
+pkgname='ros-melodic-rosbridge-library'
+pkgver='0.11.3'
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(
+ ros-melodic-catkin
+ ros-melodic-std-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-message-generation
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ python-pillow
+ python-bson
+)
+
+ros_depends=(
+ ros-melodic-rospy
+ ros-melodic-roscpp
+ ros-melodic-rosgraph
+ ros-melodic-rosservice
+ ros-melodic-rostopic
+ ros-melodic-std-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-message-runtime
+)
+
+depends=(
+ ${ros_depends[@]}
+ python-pillow
+ python-bson
+)
+
+_dir="rosbridge_suite-${pkgver}/rosbridge_library"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/RobotWebTools/rosbridge_suite/archive/${pkgver}.tar.gz")
+sha256sums=('5020616a6589f81fde0dfcd2835bbf4c43ff57bc39b76aefd5ed8f0916af87a5')
+
+build() {
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}