summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHermann von Kleist2020-05-10 13:47:40 +0200
committerHermann von Kleist2020-05-10 13:47:40 +0200
commit3c442a9cefaed6b95eb12bf3a22d9a410e855fdc (patch)
tree8e8268446fc9e3934a3d6a21fa083318f8bcfed1 /PKGBUILD
parenta5fc6e0a12b9e76517af0302311933cebb0da426 (diff)
downloadaur-3c442a9cefaed6b95eb12bf3a22d9a410e855fdc.tar.gz
Update to 1.15.2 and noetic
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecf19da915d2..6f09e356b4a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgdesc="ROS - rosbuild contains scripts for managing the CMake-based build system for ROS."
url='https://wiki.ros.org/rosbuild'
-pkgname='ros-melodic-rosbuild'
-pkgver='1.14.6'
+pkgname='ros-noetic-rosbuild'
+pkgver='1.15.2'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-melodic-catkin
+ ros-noetic-catkin
)
makedepends=(
@@ -22,9 +22,9 @@ makedepends=(
)
ros_depends=(
- ros-melodic-message-runtime
- ros-melodic-message-generation
- ros-melodic-catkin
+ ros-noetic-message-runtime
+ ros-noetic-message-generation
+ ros-noetic-catkin
)
depends=(
@@ -33,29 +33,23 @@ depends=(
_dir="ros-${pkgver}/core/rosbuild"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros/archive/${pkgver}.tar.gz")
-sha256sums=('62f1350271a76bc35794c2cdb741cdae2ba096c96a924dba025aed4f561c978c')
+sha256sums=('596bb5e04ece0ad0662d6d2ee9b4223aaa890770e83c7310ec71bf9c0c3c7b5e')
build() {
# Use ROS environment variables.
source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
# Create the build directory.
[ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
# Build the project.
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}