summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:22:57 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:22:57 +0100
commit3bed7574771fcdaced1d992ca87a366d0b8ce878 (patch)
tree46ebe8fa1ab094e482aae04b8bf9fa4eb4bcbd5a /PKGBUILD
parentf112cddb2f0303faef5e6b53cbcb4db2eea4229a (diff)
downloadaur-3bed7574771fcdaced1d992ca87a366d0b8ce878.tar.gz
New Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD82
1 files changed, 43 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79e845183409..80439355f6d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - rqt_gui provides the main to start an instance of the ROS integrated graphical user interface provided by qt_gui."
url='http://ros.org/wiki/rqt_gui'
@@ -10,52 +10,56 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin
- ros-melodic-qt-gui)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-qt-gui
+ ros-melodic-catkin
+)
-ros_depends=(ros-melodic-catkin
- ros-melodic-qt-gui)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/rqt_gui/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-qt-gui
+ ros-melodic-catkin
+)
+
+depends=(
+ ${ros_depends[@]}
+)
-# Tarball version (faster download)
_dir="rqt-release-release-melodic-rqt_gui-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt-release/archive/release/melodic/rqt_gui/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('d6a9306b14facf26f432b32e9946daa1aa3c10c6f6d053e3a701bfab10e3200a')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
-
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
-
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}