summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralex-born2021-06-19 13:00:48 -0500
committerMohammad Farzan2021-06-19 23:00:46 +0430
commit46c99a438a016d31c48fe5e16ef8493246fed3d4 (patch)
tree542aa854e7032c283188e7abf7df306e0416fd7a /PKGBUILD
parent9cdfe77176956d945d5fdce7de2dd30f9136ebc8 (diff)
downloadaur-46c99a438a016d31c48fe5e16ef8493246fed3d4.tar.gz
Fixed locale check
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a66211ba6867..01c1663612e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,11 +22,10 @@ install=ros2-foxy.install
prepare() {
# Check locale
- locale | grep LANG | grep UTF-8
- if [[ $? -ne 0 ]]; then
- printf "Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale
- or https://wiki.archlinux.org/index.php/locale ."
- exit 1
+ if [[ "$(locale | grep LANG | grep UTF-8)" == "" ]]; then
+ msg2 "ERROR: Locale must support UTF-8. See https://wiki.archlinux.org/index.php/locale or https://wiki.archlinux.org/index.php/locale";
+
+ exit 1;
fi
# Create required symlinks (see https://wiki.archlinux.org/index.php/ROS)