summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:00:41 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:00:41 -0300
commitb16b1f040ce608288b362cab30b9c182e812e946 (patch)
treeb56ed5beac567623d2c3f9795bbbf43da5fc3949 /PKGBUILD
parent14e26cfedbf9a038aab02ad6ca4a8c8321bf6b89 (diff)
downloadaur-b16b1f040ce608288b362cab30b9c182e812e946.tar.gz
update to 2.5.4-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a400de74314..ef08425a3f24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=moveit2
_pkgname=moveit_configs_utils
pkgname=ros2-humble-moveit-configs-utils
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Python library for loading moveit config parameters in launch files"
url="https://index.ros.org/p/moveit_configs_utils/"
arch=('any')
@@ -12,25 +13,20 @@ depends=(
'ros2-humble-launch-param-builder'
'ros2-humble-srdfdom'
)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
prepare() {
- source /opt/ros/humble/setup.bash
+ source /opt/ros/humble/setup.bash
}
build() {
-source /opt/ros/humble/setup.bash
- cd moveit2-$pkgver/$_pkgname
- colcon build --merge-install
+ cd "$_pkgroot-$pkgver/$_pkgname"
+ python -m build --wheel --no-isolation
}
package() {
- # Copy build files
- mkdir -p $pkgdir/opt/ros/humble
- cp -r $srcdir/moveit2-$pkgver/$_pkgname/install/* $pkgdir/opt/ros/humble/
- # Exclude files that clash with base ros installation
- rm $pkgdir/opt/ros/humble/*setup.*
- rm $pkgdir/opt/ros/humble/_local_setup*
- rm $pkgdir/opt/ros/humble/COLCON_IGNORE
+ cd "$_pkgroot-$pkgver/$_pkgname"
+ python -m installer --destdir="$pkgdir" --prefix="/opt/ros/humble" dist/*.whl
}