summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:47:30 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:47:30 -0300
commit87a8b75a4e37b36094ef0539b0c0eb311de1e60d (patch)
treed70b3facaef35926b5278d4a0abfcd21693636db /PKGBUILD
downloadaur-87a8b75a4e37b36094ef0539b0c0eb311de1e60d.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de1a163a9376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=moveit_planners/ompl
+pkgname=ros2-humble-moveit-planners-ompl
+pkgver=2.5.4
+pkgrel=1
+pkgdesc="MoveIt interface to OMPL"
+url="https://index.ros.org/p/moveit_planners_ompl/"
+arch=('any')
+makedepends=(
+ 'ros2-humble-moveit-common'
+ 'ros2-humble-moveit-resources-pr2-description'
+ 'ros2-humble-moveit-resources-fanuc-moveit-config'
+ 'ros2-humble-moveit-resources-panda-moveit-config'
+ 'eigen'
+)
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-moveit-core'
+ 'ros2-humble-moveit-msgs'
+ 'ros2-humble-moveit-ros-planning'
+ 'ompl'
+ 'openmp'
+ 'python'
+)
+source=("https://github.com/ros-planning/moveit2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('42ac45e2631d59203edfdfc2f521312f7ddef04ff5baf1fec43c65f79495d7a6')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S moveit2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}