summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-03-14 17:58:22 -0300
committerAngelo Elias Dal Zotto2023-03-14 17:58:22 -0300
commitc942807c4504b9f7ea998617d75957c4ed1be95c (patch)
tree97f30598ac562dc2402c9923542f05b1023a53b7 /PKGBUILD
downloadaur-c942807c4504b9f7ea998617d75957c4ed1be95c.tar.gz
First version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..097637cabc33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+
+_pkgname=nav2_navfn_planner
+pkgname=ros2-humble-nav2-navfn-planner
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="TODO"
+url="https://index.ros.org/p/nav2_navfn_planner/"
+arch=('any')
+depends=(
+ 'ros2-humble'
+ 'ros2-humble-nav2-util'
+ 'ros2-humble-nav2-msgs'
+ 'ros2-humble-nav2-common'
+ 'ros2-humble-nav2-costmap-2d'
+ 'ros2-humble-nav2-core'
+)
+source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+
+prepare() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -S navigation2-$pkgver/$_pkgname -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/humble
+}
+
+build() {
+ make -C build
+}
+
+package() {
+ make DESTDIR="$pkgdir/" -C build install
+}