summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 09:16:31 -0300
committerAngelo Elias Dal Zotto2023-06-10 09:16:31 -0300
commit9bd37784970741dcf2d28b06eebea5a13cf574ec (patch)
treecb12523847545091094f328accf019c0aa168b23 /PKGBUILD
parent3980a17724208fb76d47ffa7b79e18eeb271300a (diff)
downloadaur-9bd37784970741dcf2d28b06eebea5a13cf574ec.tar.gz
update to 1.1.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d47be4208f6e..155fc6febd20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,34 @@
# Maintainer: Angelo Elias Dal Zotto <angelodalzotto97@gmail.com>
+_pkgroot=navigation2
_pkgname=nav2_simple_commander
pkgname=ros2-humble-nav2-simple-commander
-pkgver=1.1.6
-pkgrel=2
+pkgver=1.1.7
+pkgrel=1
pkgdesc="An importable library for writing mobile robot applications in python3"
url="https://index.ros.org/p/nav2_simple_commander/"
arch=('any')
-makedepends=('python-pytest')
+makedepends=('python-pytest' 'cmake')
depends=(
'ros2-humble'
'ros2-humble-nav2-msgs'
)
source=("https://github.com/ros-planning/navigation2/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('43abfa0eba8e3862e9f69e39399b0b6b627d2fa44faede494b09b7ee8c2626c1')
+sha256sums=('1d89dc1ad7c75d4d1645c882a5aee037ca965908344a158bb9669ad80a85196b')
prepare() {
source /opt/ros/humble/setup.bash
}
build() {
-source /opt/ros/humble/setup.bash
- cd navigation2-$pkgver/$_pkgname
- colcon build --merge-install
+ cmake -B build -S "$_pkgroot-$pkgver/$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
}
package() {
- # Copy build files
- mkdir -p $pkgdir/opt/ros/humble
- cp -r $srcdir/navigation2-$pkgver/$_pkgname/install/* $pkgdir/opt/ros/humble/
- # Exclude files that clash with base ros installation
- rm $pkgdir/opt/ros/humble/*setup.*
- rm $pkgdir/opt/ros/humble/_local_setup*
- rm $pkgdir/opt/ros/humble/COLCON_IGNORE
+ DESTDIR="$pkgdir" cmake --install build
}