summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Elias Dal Zotto2023-06-10 10:27:49 -0300
committerAngelo Elias Dal Zotto2023-06-10 10:27:49 -0300
commitd8d9ab4587a666070beee5adb9c862ebe34333f1 (patch)
tree011794b32f7111af97612b4d92fb3e6f16774687 /PKGBUILD
parent3b8110db951795221ae43b7c1fb7bebbeb77e612 (diff)
downloadaur-d8d9ab4587a666070beee5adb9c862ebe34333f1.tar.gz
update to 1.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4490f284af5a..7c16f0e1572d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=urdf_parser_py
pkgname=ros2-humble-urdf-parser-py
-pkgver=1.2.0
-pkgrel=2
+pkgver=1.2.1
+pkgrel=1
pkgdesc="Python implementation of the URDF parser"
url="https://index.ros.org/p/urdf_parser_py/"
arch=('any')
@@ -13,25 +13,20 @@ depends=(
'python-lxml'
'python-yaml'
)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/ros/urdf_parser_py/archive/refs/tags/${pkgver}.tar.gz")
sha256sums=('ea7ca336bf0e7d47048769634eb3ca63fc773cbdeef8ed2a7c38230151cc3b45')
prepare() {
- source /opt/ros/humble/setup.bash
+ source /opt/ros/humble/setup.bash
}
build() {
-source /opt/ros/humble/setup.bash
- cd urdf_parser_py-$pkgver
- colcon build --merge-install
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- # Copy build files
- mkdir -p $pkgdir/opt/ros/humble
- cp -r $srcdir/urdf_parser_py-$pkgver/install/* $pkgdir/opt/ros/humble/
- # Exclude files that clash with base ros installation
- rm $pkgdir/opt/ros/humble/*setup.*
- rm $pkgdir/opt/ros/humble/_local_setup*
- rm $pkgdir/opt/ros/humble/COLCON_IGNORE
+ cd "$_pkgroot-$pkgver/$_pkgname"
+ python -m installer --destdir="$pkgdir" --prefix="/opt/ros/humble" dist/*.whl
}