summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2016-08-07 13:27:31 +0200
committerCarsten Teibes2016-08-07 13:27:31 +0200
commit54c22efcbd0a5ebe730e3d03f83ad40c3f68dbab (patch)
treee4309d22be0063895443ec586f59632d58397107 /PKGBUILD
parent6f2ab00b0b7b58d00518eae3498b9ece8c545e12 (diff)
downloadaur-rott-svn.tar.gz
[upd] Adapt to new build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 12 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5b5b0d210c1..14ee2887b8e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=rott-svn
-pkgver=1.1.2.r278
+pkgver=1.1.2.r287
pkgrel=1
pkgdesc='"Rise of the Triad" is a high quality first-person perspective 3D action game (development version)'
arch=('i686' 'x86_64')
@@ -9,10 +9,8 @@ license=('GPL2')
makedepends=('svn')
depends=('sdl_mixer')
url="http://icculus.org/rott/"
-source=(rott::"svn://svn.icculus.org/rott/trunk"
- "rott.sh")
-sha256sums=('SKIP'
- '19f5c5ccf4b6bd592a8e119f8172a0cb180caf1ab831b820786000dbeaf9651e')
+source=(rott::"svn://svn.icculus.org/rott/trunk")
+sha256sums=('SKIP')
pkgver() {
cd rott
@@ -22,21 +20,20 @@ pkgver() {
build() {
cd rott
- # We can not just build all editions, because of a Makefile quirk. Object files will overlap when parallel building is used (-j2).
- # You can choose your edition(s) here:
- make rott-huntbgin # shareware
- make rott-darkwar # commercial
- make rott-rottcd # cd
- #make rott-rottsite # site license cd
+ autoreconf -fi
+ ./configure --enable-suffix=registered
+ make
+
+ ./configure --enable-shareware --enable-suffix=shareware
+ make
}
package() {
cd rott
- # copy all editions and launcher
- install -d "$pkgdir"/usr/bin
- install -m755 rott-* "$pkgdir"/usr/bin
+ # copy both editions and launcher
+ install -Dm755 rott/rott-registered "$pkgdir"/usr/bin/rott
+ install -m755 rott/rott-shareware "$pkgdir"/usr/bin
install -m755 misc/runrott.sh "$pkgdir"/usr/bin/runrott
- install -m755 ../rott.sh "$pkgdir"/usr/bin/rott
# doc
install -Dm644 doc/rott.6 "$pkgdir"/usr/share/man/man6/rott.6
install -d "$pkgdir"/usr/share/doc/$pkgname
@@ -44,8 +41,4 @@ package() {
# .desktop entry
install -Dm644 misc/rott.png "$pkgdir"/usr/share/pixmaps/rott.png
install -Dm644 misc/rott.desktop "$pkgdir"/usr/share/applications/rott.desktop
-
- # set the cd version as default (as it is a common version, for example still sold at gog.com)
- # You can also use all other targets from the build() function, for example 'huntbgin' for the shareware version
- sed 's|EDITION|rottcd|' -i "$pkgdir"/usr/bin/rott
}