summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2018-09-01 09:45:27 +0200
committerMaxime Gauduin2018-09-01 09:45:27 +0200
commitafe1476810711a3ee53d838646c52f47ed201e3c (patch)
tree6dc0b458928de637779053b3fbc914fe71f014b0 /PKGBUILD
parent253b787b84025fc363ec93bd3324ad6b0be11c9e (diff)
downloadaur-afe1476810711a3ee53d838646c52f47ed201e3c.tar.gz
Remove deprecated submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e78372b7ee76..eb8c4b4322f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.5.r772.b095a0be9
+pkgver=0.0.5.r821.bf89b709c
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=('x86_64')
@@ -24,7 +24,6 @@ source=('git+https://github.com/RPCS3/rpcs3.git'
'git+https://github.com/kobalicek/asmjit.git'
'git+https://github.com/Microsoft/GSL.git'
'git+https://github.com/KhronosGroup/glslang.git'
- 'git+https://github.com/akrzemi1/Optional.git'
'git+https://github.com/zeux/pugixml.git'
'git+https://github.com/Cyan4973/xxHash.git'
'git+https://github.com/jbeder/yaml-cpp.git')
@@ -37,7 +36,6 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -49,17 +47,16 @@ pkgver() {
prepare() {
pushd rpcs3
- git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
+ git submodule init 3rdparty/{GSL,hidapi,pugixml,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
git config submodule.asmjit.url ../asmjit
git config submodule.glslang.url ../glslang
git config submodule.GSL.url ../GSL
git config submodule.hidapi.url ../rpcs3-hidapi
git config submodule.llvm.url ../rpcs3-llvm
- git config submodule.Optional.url ../Optional
git config submodule.pugixml.url ../pugixml
git config submodule.xxHash ../xxHash
git config submodule.yaml-cpp ../yaml-cpp
- git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
+ git submodule update 3rdparty/{GSL,hidapi,pugixml,xxHash,yaml-cpp} asmjit llvm Vulkan/glslang
popd
@@ -75,11 +72,11 @@ build() {
cmake ../rpcs3 \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_EXE_LINKER_FLAGS='-ldl' \
-DCMAKE_SKIP_RPATH='ON' \
-DUSE_SYSTEM_FFMPEG='ON' \
-DUSE_SYSTEM_LIBPNG='ON' \
- -DBUILD_XXHSUM='OFF'
+ -DUSE_NATIVE_INSTRUCTIONS='OFF'
+ #-DCMAKE_EXE_LINKER_FLAGS='-ldl' \
make
}