summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2018-05-13 19:15:08 +0200
committerMaxime Gauduin2018-05-13 19:15:08 +0200
commitc9ecd0740c4261c51dec12d9f660fe19673a643e (patch)
treea912aa730f2aa02a78e2e326e001b4cd1fa67fd9 /PKGBUILD
parent1113f24f411a62a17467d8733f8810860dc16f97 (diff)
downloadaur-c9ecd0740c4261c51dec12d9f660fe19673a643e.tar.gz
New xxHash dep
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50740b047b05..9f00337991b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.5.r258.737db9005
-pkgrel=3
+pkgver=0.0.5.r275.84a4671a0
+pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=('x86_64')
url='https://github.com/RPCS3/rpcs3'
@@ -15,6 +15,7 @@ depends=('alsa-lib' 'gcc-libs' 'glew' 'glibc' 'glu' 'libevdev' 'libgl' 'libice'
makedepends=('boost' 'cereal' 'cmake' 'ffmpeg' 'git')
provides=('rpcs3')
conflicts=('rpcs3')
+options=('!emptydirs')
source=('git+https://github.com/RPCS3/rpcs3.git'
'rpcs3-common::git+https://github.com/RPCS3/common.git'
'rpcs3-hidapi::git+https://github.com/RPCS3/hidapi.git'
@@ -24,7 +25,8 @@ source=('git+https://github.com/RPCS3/rpcs3.git'
'git+https://github.com/KhronosGroup/glslang.git'
'git+https://github.com/akrzemi1/Optional.git'
'git+https://github.com/zeux/pugixml.git'
- 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git')
+ 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git'
+ 'git+https://github.com/Cyan4973/xxHash.git')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -33,6 +35,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -44,7 +47,7 @@ pkgver() {
prepare() {
pushd rpcs3
- git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
+ git submodule init 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
git config submodule.asmjit.url ../asmjit
git config submodule.glslang.url ../glslang
git config submodule.GSL.url ../GSL
@@ -53,7 +56,8 @@ prepare() {
git config submodule.Optional.url ../Optional
git config submodule.pugixml.url ../pugixml
git config submodule.Vulkan-LoaderAndValidationLayers ../Vulkan-LoaderAndValidationLayers
- git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
+ git config submodule.xxHash ../xxHash
+ git submodule update 3rdparty/{GSL,hidapi,Optional,pugixml,xxHash} asmjit Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
sed 's/999.666/6.0.0/' -i rpcs3/CMakeLists.txt
@@ -74,12 +78,15 @@ build() {
-DCMAKE_EXE_LINKER_FLAGS='-ldl -lyaml-cpp' \
-DCMAKE_SKIP_RPATH='ON' \
-DUSE_SYSTEM_FFMPEG='ON' \
- -DUSE_SYSTEM_LIBPNG='ON'
+ -DUSE_SYSTEM_LIBPNG='ON' \
+ -DBUILD_SHARED_LIBS='OFF'
make
}
package() {
make DESTDIR="${pkgdir}" -C build install
+ find "${pkgdir}" -name *xxhsum* -delete
+ find "${pkgdir}" -name *xxhash* -delete
}
# vim: ts=2 sw=2 et: