summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime Gauduin2016-08-28 13:52:57 +0200
committerMaxime Gauduin2016-08-28 13:52:57 +0200
commitcfe454a7020a60632bdc18c561e940a8b086f455 (patch)
tree89200ed19fcbe119a92c873ab21ade56dc2a9987 /PKGBUILD
parent4b23ecb08ce06b2b6c9e9ab591a8d3410501e810 (diff)
downloadaur-cfe454a7020a60632bdc18c561e940a8b086f455.tar.gz
rpcs3-git 0.0.0.9.r324.5f15c66-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 18 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e0af6929170..8ce7f9e5cd4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=rpcs3-git
-pkgver=0.0.0.9.r126.effd379
+pkgver=0.0.0.9.r324.5f15c66
pkgrel=1
pkgdesc='A Sony PlayStation 3 emulator'
arch=('x86_64')
url='https://github.com/DHrpcs3/rpcs3'
license=('GPL2')
-depends=('boost-libs' 'gcc-libs' 'glew' 'glibc' 'libgl' 'libx11' 'openal'
- 'wxgtk'
- 'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libswscale.so')
-makedepends=('boost' 'cmake' 'git' 'yaml-cpp')
+depends=('gcc-libs' 'glew' 'glibc' 'glu' 'libgl' 'libpng' 'libx11' 'openal'
+ 'wxgtk' 'yaml-cpp' 'zlib'
+ 'libavcodec.so' 'libavformat.so' 'libavutil.so' 'libncursesw.so'
+ 'libswscale.so' 'libswresample.so')
+makedepends=('boost' 'cereal' 'cmake' 'git' 'llvm')
provides=('rpcs3')
conflicts=('rpcs3')
source=('git+https://github.com/RPCS3/rpcs3.git'
- 'git+https://github.com/RPCS3/common'
- 'git+https://github.com/RPCS3/pugixml'
- 'git+https://github.com/RPCS3/rsx_program_decompiler.git'
+ 'git+https://github.com/RPCS3/common.git'
+ 'git+https://github.com/RPCS3/pugixml.git#commit=f205aaf'
+ 'git+https://github.com/RPCS3/rsx-debugger.git#commit=3b11b96'
+ 'git+https://github.com/RPCS3/rsx_program_decompiler.git#commit=de3b205'
'git+https://github.com/kobalicek/asmjit.git#commit=b0dad1a'
'git+https://github.com/Microsoft/GSL.git#commit=fc5fce4'
- 'git+https://github.com/KhronosGroup/glslang.git#commit=3c5b1e6'
- 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=1affe90')
+ 'git+https://github.com/KhronosGroup/glslang.git#commit=2921e0c'
+ 'git+https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git#commit=64d375f')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -28,6 +30,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -45,10 +48,11 @@ prepare() {
cd ../rpcs3
- git submodule init 3rdparty/{GSL,pugixml} asmjit rsx_program_decompiler Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
+ git submodule init 3rdparty/{GSL,pugixml} asmjit rsx{-debugger,_program_decompiler} Vulkan/{glslang,Vulkan-LoaderAndValidationLayers}
git config submodule.asmjit.url ../asmjit
git config submodule.GSL.url ../GSL
git config submodule.pugixml.url ../pugixml
+ git config submodule.rsx-debugger.url ../rsx-debugger
git config submodule.rsx_program_decompiler.url ../rsx_program_decompiler
git config submodule.glslang.url ../glslang
git config submodule.Vulkan-LoaderAndValidationLayers ../Vulkan-LoaderAndValidationLayers
@@ -66,9 +70,10 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
-DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_EXE_LINKER_FLAGS='-ldl -lyaml-cpp' \
-DCMAKE_SKIP_RPATH='ON' \
- -DUSE_SYSTEM_LIBPNG='ON' \
- -DUSE_SYSTEM_FFMPEG='ON'
+ -DUSE_SYSTEM_FFMPEG='ON' \
+ -DUSE_SYSTEM_LIBPNG='ON'
make
}