summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan D. Scott2016-02-14 12:08:52 -0800
committerIan D. Scott2016-02-14 12:08:52 -0800
commit0a0cf9608ac4e4bb529762dce1d462026bb1187f (patch)
treec6411ed74834003d9d1339c10361268d955081e2 /PKGBUILD
parenteb6d8600df7ea9661e6afbf9e29889d6b8290f5e (diff)
downloadaur-0a0cf9608ac4e4bb529762dce1d462026bb1187f.tar.gz
Put cache in writeable location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f74f41ddd1b..caac544391a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rpython
pkgver=0.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="Restricted python compiler"
url="http://pypy.org"
arch=('any')
@@ -11,6 +11,11 @@ license=('MIT')
source=("https://pypi.python.org/packages/source/r/rpython/rpython-${pkgver}.tar.gz")
md5sums=('680fcee2fed5f94fcb4390130510eec9')
+prepare() {
+ cd ${pkgname}-$pkgver
+ # Put cache in writable location
+ sed -i "s|os.path.realpath(os.path.join(MAINDIR, '_cache'))|os.path.expanduser('~/.cache/rpython')|" rpython/config/translationoption.py
+}
package() {
cd ${pkgname}-$pkgver