summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordequis2016-10-01 20:53:56 -0300
committerdequis2016-10-01 20:54:08 -0300
commit66d35137932be72234f207bfcfa62033cea9e54d (patch)
tree297ae8111ef0f0affb947b574cb402bbb03f5d8b /PKGBUILD
parenta75c350983aaed8f9dbb626bffd650f17994bbe1 (diff)
downloadaur-66d35137932be72234f207bfcfa62033cea9e54d.tar.gz
4.4.0 + git commit b17311c
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2cf733c24ace..c2933fdae7ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Previous maintainer: Joel Teichroeb <joel@teichroeb.net>
pkgname=rr
-pkgver=4.3.0
-pkgrel=2
+pkgver=4.4.0
+pkgrel=1
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -11,12 +11,17 @@ license=('custom')
depends=('python2-pexpect' 'gdb')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
-source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz)
-sha1sums=('abaf0e13d0e1c80b30846507c7af574484b819e0')
+source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
+ https://github.com/mozilla/rr/commit/b17311c9f7720512f3a25e820c212d09d5799bcd.patch)
+sha1sums=('3807fb7df4de049ca2dd65d1718fc8034c84bee8'
+ 'd453f07e8bee6be2e44b19b079ec030ba5fff968')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
+
+ # Make ptrace test work if compiled with PIC
+ patch -p1 -i ../b17311c9f7720512f3a25e820c212d09d5799bcd.patch
}
build() {