summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCody P Schafer2023-02-20 11:58:32 -0500
committerCody P Schafer2023-02-20 11:58:43 -0500
commit80d2eeaec425f698bf971973fdb9ee7195cdee18 (patch)
tree0833faf52ef3ad3a1d8507b4a4b098acacfe0687 /PKGBUILD
parent54f0008f3166400791f7e004e99d7b2ea63cbc07 (diff)
downloadaur-80d2eeaec425f698bf971973fdb9ee7195cdee18.tar.gz
patch for ethtool_sset_info issue reported by @angelv
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 970c2ffc9dd8..01bfc1d72789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rr
pkgver=5.6.0
-pkgrel=1
+pkgrel=2
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -15,12 +15,15 @@ options=(!strip)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/rr-debugger/${pkgname}/archive/${pkgver}.tar.gz
+ https://github.com/rr-debugger/rr/commit/2979c60ef8bbf7c940afd90172ddc5d8863f766e.patch
)
-sha1sums=('9a047cbd1c47ef1585293ba090c5cd2d56519fa6')
+sha1sums=('9a047cbd1c47ef1585293ba090c5cd2d56519fa6'
+ '7faf899f31ee8e9e47a6ab8dce261cf64b235c6c')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
+ patch -p1 -N -i ../2979c60ef8bbf7c940afd90172ddc5d8863f766e.patch
}
build() {