summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCody P Schafer2023-05-10 18:17:42 -0400
committerCody P Schafer2023-05-10 18:17:42 -0400
commit92fee8ef304acfe40ffa160d4b2f3d52896fb429 (patch)
tree8d78eb079a9db8366688dc84c769a72986983898 /PKGBUILD
parent80d2eeaec425f698bf971973fdb9ee7195cdee18 (diff)
downloadaur-92fee8ef304acfe40ffa160d4b2f3d52896fb429.tar.gz
patch for gcc 13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01bfc1d72789..d43e6c57b441 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=rr
pkgver=5.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
@@ -16,14 +16,17 @@ options=(!strip)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/rr-debugger/${pkgname}/archive/${pkgver}.tar.gz
https://github.com/rr-debugger/rr/commit/2979c60ef8bbf7c940afd90172ddc5d8863f766e.patch
+ https://github.com/rr-debugger/rr/commit/2248c85c424e8c257ca88af2732782574d6a3544.patch
)
sha1sums=('9a047cbd1c47ef1585293ba090c5cd2d56519fa6'
- '7faf899f31ee8e9e47a6ab8dce261cf64b235c6c')
+ '7faf899f31ee8e9e47a6ab8dce261cf64b235c6c'
+ '69e2324990d81a8013391537bd3ebd4460c673d9')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
patch -p1 -N -i ../2979c60ef8bbf7c940afd90172ddc5d8863f766e.patch
+ patch -p1 -N -i ../2248c85c424e8c257ca88af2732782574d6a3544.patch
}
build() {