summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCody P Schafer2019-12-04 00:55:13 -0500
committerCody P Schafer2019-12-04 00:55:13 -0500
commite801137554957efc1c301c7add0a7e4d6ee08e43 (patch)
treebab652fb06a54be366a6dd3d6e6cff90a04cf745 /PKGBUILD
parentb4ddcd3be38a6725659be4b8148999a53b18c9a2 (diff)
downloadaur-e801137554957efc1c301c7add0a7e4d6ee08e43.tar.gz
disable stripping
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1a3a16d946b..bac61224ee66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,15 @@
pkgname=rr
pkgver=5.2.0
-pkgrel=4
+pkgrel=5
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
url='http://rr-project.org/'
license=('custom')
depends=('gdb' 'capnproto')
makedepends=('git' 'cmake' 'gdb' 'ninja')
+options=(!strip)
+
source=(
$pkgname-$pkgver.tar.gz::https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
https://github.com/mozilla/rr/commit/53c5bd72bae089616a3ca626b8af240481d70e6f.patch
@@ -46,6 +48,9 @@ build() {
package() {
cd $pkgname-$pkgver/build
DESTDIR="${pkgdir}" cmake --build . -- -v install
+ if check_option 'debug' n; then
+ find "${pkgdir}/usr/bin" -type f -executable -exec strip $STRIP_BINARIES {} + || :
+ fi
cd ..
install -D LICENSE "${pkgdir}/usr/share/licenses/rr/LICENSE"
}