summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordequis2017-02-04 11:52:04 -0300
committerdequis2017-02-04 11:52:04 -0300
commitc5ebfac62071fa47579ddecc664c0021e5d9a686 (patch)
tree43f4a34786ce2cc3db7372d7a5e38377d38bdfea /PKGBUILD
parent66d35137932be72234f207bfcfa62033cea9e54d (diff)
downloadaur-c5ebfac62071fa47579ddecc664c0021e5d9a686.tar.gz
4.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2933fdae7ce..937a8947a9aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Previous maintainer: Joel Teichroeb <joel@teichroeb.net>
pkgname=rr
-pkgver=4.4.0
+pkgver=4.5.0
pkgrel=1
pkgdesc='Record and Replay framework: lightweight recording and deterministic debugging'
arch=(i686 x86_64)
@@ -11,17 +11,12 @@ license=('custom')
depends=('python2-pexpect' 'gdb')
makedepends=('git' 'cmake' 'gdb')
[ "$CARCH" = 'x86_64' ] && makedepends+=('gcc-multilib')
-source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz
- https://github.com/mozilla/rr/commit/b17311c9f7720512f3a25e820c212d09d5799bcd.patch)
-sha1sums=('3807fb7df4de049ca2dd65d1718fc8034c84bee8'
- 'd453f07e8bee6be2e44b19b079ec030ba5fff968')
+source=(https://github.com/mozilla/${pkgname}/archive/${pkgver}.tar.gz)
+sha1sums=('70d3902c36fb1d0cd423cf1046df06f5153cba5b')
prepare() {
cd $pkgname-$pkgver
mkdir -p build
-
- # Make ptrace test work if compiled with PIC
- patch -p1 -i ../b17311c9f7720512f3a25e820c212d09d5799bcd.patch
}
build() {