summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWalter Dworak2015-09-09 09:18:53 -0500
committerWalter Dworak2015-09-09 09:18:53 -0500
commit53d02654fd404e3b52c63c09d806e5dc826401a6 (patch)
treed7b76b8002258035faef79e134100be35658772c /PKGBUILD
downloadaur-53d02654fd404e3b52c63c09d806e5dc826401a6.tar.gz
Initial Package Release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96ccb0cb24e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+#Maintainer: Walter Dworak <preparatioh67 at gmail dot com>
+# Contributor: Alessandro Sagratini <ale_sagra at hotmail dot com>
+pkgname=rr62x
+pkgver=1.2
+pkgrel=1
+pkgdesc="Kernel modules for Highpoint RocketRAID 62x SATA/6Gbps Card."
+arch=('i686' 'x86_64')
+url="http://www.highpoint-tech.com/USA_new/series_rr600-download.htm"
+license=('custom')
+groups=()
+
+depends=('linux')
+makedepends=('linux-headers')
+
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=$pkgname.install
+source=(http://www.highpoint-tech.com/BIOS_Driver/rr62x/linux/rr62x-linux-src-v1.2-120601-1355.tar.gz linux_4.patch)
+noextract=()
+md5sums=('b308bcba65d065cddf05d9b7dea8f3d6' 'd4fbdc757b8e061410396f0c829958f9')
+_extramodules=extramodules-"$(uname -r | cut -d. -f1,2)"-ARCH
+_kernver="$(uname -r)"
+
+build() {
+ if [ ! -e /lib/modules/$_kernver/build/ ]; then
+ echo Cannot find kernel souce code from /lib/modules/$_kernver/build/
+ exit 1
+ fi
+ cd $srcdir/
+ # Apply the Linux version 4 patch
+ patch -p0 < ./linux_4.patch
+
+ cd rr62x-linux-src-v$pkgver/product/rr62x/linux/
+ make || return 1
+}
+
+package() {
+ cd rr62x-linux-src-v$pkgver/product/rr62x/linux/
+
+ # Install the kernel module
+ #mkdir -p "${pkgdir}/usr/lib/modules/${_extramodules}/"
+ install -m 644 -D rr62x.ko "${pkgdir}/usr/lib/modules/${_extramodules}/drivers/scsi/rr62x/rr62x.ko"
+ gzip "${pkgdir}/usr/lib/modules/${_extramodules}/rr62x.ko"
+
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cp $srcdir/rr62x-linux-src-v$pkgver/README $pkgdir/usr/share/licenses/$pkgname/
+}