summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKirill Minligareev2022-07-09 21:03:50 +0500
committerKirill Minligareev2022-07-09 21:03:50 +0500
commite968ffc614aca111e2a170446bee94ad33f8b89d (patch)
treea36492e2b44895ea2d8fce0bb962d1be9c3f3e1d /PKGBUILD
downloadaur-e968ffc614aca111e2a170446bee94ad33f8b89d.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7901b70204a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=rsgain-git
+pkgver=2.0.1
+pkgrel=1
+epoch=
+pkgdesc="ReplayGain 2.0 loudness normalizer"
+arch=('x86_64')
+url="https://github.com/complexlogic/rsgain"
+license=('BSD')
+groups=()
+depends=('libebur128' 'taglib' 'libavformat.so' 'libavcodec.so' 'libswresample.so' 'libavutil.so' 'libinih')
+makedepends=('cmake')
+provides=('rsgain')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/complexlogic/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}
+