summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-09-01 01:29:46 -0700
committerxiota2023-09-01 01:29:46 -0700
commit495ce9d63ad73e9f4d9f869cd7513a81c9758773 (patch)
tree350fd652673bdc0160a3422ba4d69529dd8a3149 /PKGBUILD
parent876e77cb27926e22abdff19b719fb57803b4bb5e (diff)
downloadaur-495ce9d63ad73e9f4d9f869cd7513a81c9758773.tar.gz
Move quarto detection back into build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5bb923edbf0..254cbfa92990 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ _nodever=16.14.0
_pandocver="current"
_quarto="FALSE"
-pkgrel=2
+pkgrel=3
pkgdesc="A powerful and productive integrated development environment (IDE) for R programming language"
arch=('x86_64')
url="https://www.rstudio.com/products/rstudio/"
@@ -41,14 +41,6 @@ sha256sums=('83469a4b7311d745c24d7d9e55c44aa4325dda3bdde50a903e2f9ead47d75cc7'
noextract=("gin-${_ginver}.zip")
-# Choose build options: either with or without quarto
-if (pacman -Q quarto >/dev/null 2>/dev/null) ; then
- _quarto="TRUE"
- makedepends+=('quarto')
-else
- _quarto="FALSE"
-fi
-
prepare() {
cd ${srcdir}/${_srcname}
# Do not use outdated version name of pandoc
@@ -78,13 +70,15 @@ prepare() {
build() {
# Quarto set up
- if [ ${_quarto} = "TRUE" ]; then
+ if (pacman -Q quarto >/dev/null 2>/dev/null) ; then
+ _quarto="TRUE"
msg "Quarto is installed, include it to build"
cd "${srcdir}/${_srcname}/dependencies"
install -d quarto/bin/tools
ln -sfT /usr/bin/quarto quarto/bin/quarto
ln -sfT /usr/bin/pandoc quarto/bin/tools/pandoc
else
+ _quarto="FALSE"
msg "Quarto is not installed, use Pandoc"
cd "${srcdir}/${_srcname}/dependencies"
install -d pandoc/${_pandocver}/bin/tools