summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArtem Klevtsov2017-09-14 11:30:26 +0700
committerArtem Klevtsov2017-09-14 11:30:26 +0700
commit4edb9367013008d33544f03dd98c0e974c0a5338 (patch)
treeea0f581222ba0a50d24edf119895f0136c464c19 /PKGBUILD
parent185d1ad8daef19b9ba925ad499267821a0dd1caa (diff)
downloadaur-4edb9367013008d33544f03dd98c0e974c0a5338.tar.gz
Update clang version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe4d8545db29..4fd32719bbdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgname=rstudio-desktop-git
_gitname=rstudio
-pkgver=1.1.215
+pkgver=1.1.365
_gwtver=2.7.0
_ginver=1.5
-_clangver=3.8.0
+_clangver=4.0.1
pkgrel=1
pkgdesc="A powerful and productive integrated development environment (IDE) for R programming language"
arch=('i686' 'x86_64')
@@ -48,13 +48,14 @@ prepare() {
cp -r "${srcdir}/gwt-${_gwtver}/"* lib/gwt/${_gwtver}
cd "${srcdir}/${_gitname}/dependencies/common"
- install -d dictionaries pandoc libclang/{3.5,builtin-headers}
+ install -d pandoc libclang/{3.5,builtin-headers}
- ln -sfT "/usr/share/mathjax" mathjax-26
- ln -sfT "/usr/bin/pandoc" pandoc/pandoc
- ln -sfT "/usr/bin/pandoc-citeproc" pandoc/pandoc-citeproc
- ln -sfT "/usr/lib/libclang.so" libclang/3.5/libclang.so
- ln -sfT "/usr/lib/clang/$_clangver/include" libclang/builtin-headers/3.5
+ ln -sfT /usr/share/myspell/dicts dictionaries
+ ln -sfT /usr/share/mathjax mathjax-26
+ ln -sfT /usr/bin/pandoc pandoc/pandoc
+ ln -sfT /usr/bin/pandoc-citeproc pandoc/pandoc-citeproc
+ ln -sfT /usr/lib/libclang.so libclang/3.5/libclang.so
+ ln -sfT /usr/lib/clang/$_clangver/include libclang/builtin-headers/3.5
msg "Downloading and installing R packages..."
bash install-packages