summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2021-01-17 21:02:22 +0100
committerChristian Hesse2021-01-17 21:02:22 +0100
commite12c5c8a4841da28a434d07d1f9d7f18777d0a7b (patch)
treeffff5e0f6bb2c1f7ce49d74f8fabd8da4f215b59 /PKGBUILD
parenta7c83a7add9fc0f2d9c61c01b31f484c988ab794 (diff)
downloadaur-rsync-git.tar.gz
commit rsync-git 3.2.3.r47.gec1d5d56-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 33 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98442d68d96b..1acc893c933a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,67 +5,68 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=rsync-git
-pkgver=3.1.1.r0.g7cb0de6
+pkgver=3.2.3.r47.gec1d5d56
pkgrel=1
-pkgdesc="A file transfer program to keep remote files in sync - git checkout"
+pkgdesc='A fast and versatile file copying tool for remote and local files - git checkout'
arch=('i686' 'x86_64')
-url="http://rsync.samba.org/"
+url='https://rsync.samba.org/'
license=('GPL3')
-depends=('perl' 'popt' 'acl' 'zlib')
-makedepends=('git' 'yodl')
+depends=('acl' 'libacl.so' 'lz4' 'openssl' 'perl' 'popt' 'xxhash' 'libxxhash.so'
+ 'zlib' 'zstd')
+makedepends=('git' 'python-commonmark')
provides=('rsync')
conflicts=('rsync')
-backup=('etc/rsyncd.conf' 'etc/xinetd.d/rsync')
-source=('git://git.samba.org/rsync.git'
- 'rsyncd.conf' 'rsync.xinetd' 'rsyncd.service'
- 'rsyncd.socket' 'rsyncd@.service')
+backup=('etc/rsyncd.conf'
+ 'etc/xinetd.d/rsync')
+source=("git+https://github.com/WayneD/rsync"
+ 'rsyncd.conf')
sha256sums=('SKIP'
- '733ccb571721433c3a6262c58b658253ca6553bec79c2bdd0011810bb4f2156b'
- 'da0ec9ce07bf2edafbc8e44020da29a58038b00c3048a22de57017c56318a767'
- 'a227bf3c2218e0de1e7396751244ea92dd410600a6469f283f0fa3bead56cd0a'
- '551f17407de0e539c8419fc2cd48dd0124eb0253a186690b165b51703ffad1a5'
- 'b8ab53dde01be38e57f49d29941841249eb74a9f137ff2e28cc985acc5199492')
+ '733ccb571721433c3a6262c58b658253ca6553bec79c2bdd0011810bb4f2156b')
pkgver() {
- cd rsync/
+ cd "$srcdir/rsync"
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}
build() {
- cd rsync/
+ cd "$srcdir/rsync"
- ./prepare-source
- ./configure --prefix=/usr \
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
--with-included-popt=no \
- --with-included-zlib=no \
- --enable-acl-support \
- --enable-xattr-support \
- --disable-debug
+ --with-included-zlib=no
make
}
check() {
- cd rsync/
+ cd "$srcdir/rsync"
make test
}
package() {
- cd rsync
+ cd "$srcdir/rsync"
make DESTDIR="${pkgdir}" install
- install -Dm644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"
- install -Dm644 ../rsync.xinetd "$pkgdir/etc/xinetd.d/rsync"
- install -Dm644 ../rsyncd.service "$pkgdir/usr/lib/systemd/system/rsyncd.service"
- install -m644 ../rsyncd.socket "$pkgdir/usr/lib/systemd/system/rsyncd.socket"
- install -m644 ../rsyncd@.service "$pkgdir/usr/lib/systemd/system/rsyncd@.service"
- install -Dm755 support/rrsync "$pkgdir/usr/lib/rsync/rrsync"
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"
+ install -Dm0644 packaging/lsb/rsync.xinetd "$pkgdir/etc/xinetd.d/rsync"
+ install -Dm0644 packaging/systemd/rsync.service "$pkgdir/usr/lib/systemd/system/rsyncd.service"
+ install -Dm0644 packaging/systemd/rsync.socket "$pkgdir/usr/lib/systemd/system/rsyncd.socket"
+ install -Dm0644 packaging/systemd/rsync@.service "$pkgdir/usr/lib/systemd/system/rsyncd@.service"
+ install -Dm0755 support/rrsync "$pkgdir/usr/lib/rsync/rrsync"
}