summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-01-29 13:28:49 -0800
committerxiota2023-01-29 13:37:12 -0800
commit6dadb4fe9c821e10e65f9f18537c74edfa2e30a3 (patch)
tree102e6accbe88e193b1c6ea4fee50f61ceaa5ba73 /PKGBUILD
parent288c4f412fb9fb5c4fb737203cef4265a57922e7 (diff)
downloadaur-6dadb4fe9c821e10e65f9f18537c74edfa2e30a3.tar.gz
3.2.7-3
- remove extraneous depends - add optdepends: python
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 19 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bf73e90c6a1..20a49521f89a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,33 @@
# https://github.com/archlinux/svntogit-packages/tree/packages/rsync
_pkgname=rsync
-pkgname=rsync-reflink
-_tag='b13e7a8ef4fa430223f66403506fb821caae5cfd' # git rev-parse v${pkgver}
+pkgname="$_pkgname-reflink"
pkgver=3.2.7
-pkgrel=2
+pkgrel=3
pkgdesc='A fast and versatile file copying tool for remote and local files - with reflink support'
arch=('x86_64')
url='https://rsync.samba.org/'
license=('GPL3')
-depends=('acl' 'libacl.so' 'lz4' 'openssl' 'perl' 'popt' 'xxhash' 'libxxhash.so' 'zlib' 'zstd')
+depends=(
+ 'acl'
+ 'libacl.so'
+ 'libxxhash.so'
+ 'popt'
+ 'xxhash'
+ 'zstd'
+)
+optdepends=(
+ 'python: for rrsync'
+)
makedepends=('git' 'python-commonmark')
-provides=("${_pkgname}")
+provides=("$_pkgname")
conflicts=(${provides[@]})
backup=(
'etc/rsyncd.conf'
'etc/xinetd.d/rsync'
)
source=(
- "git+https://github.com/WayneD/rsync#tag=v${pkgver}"
+ "$_pkgname"::"git+https://github.com/WayneD/rsync#tag=v${pkgver}"
'https://github.com/WayneD/rsync-patches/raw/master/clone-dest.diff'
'https://github.com/WayneD/rsync-patches/raw/master/detect-renamed.diff'
'https://github.com/WayneD/rsync-patches/raw/master/detect-renamed-lax.diff'
@@ -39,7 +48,7 @@ _reverts=(
)
prepare() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$_pkgname"
local _c
for _c in "${_backports[@]}"; do
@@ -62,7 +71,7 @@ prepare() {
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$_pkgname"
./configure \
--prefix=/usr \
@@ -73,12 +82,12 @@ build() {
}
check() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$_pkgname"
make test
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
install -Dm0644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"