summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2024-03-17 02:07:29 +0000
committerxiota2024-03-17 02:07:29 +0000
commitbb9cef306b1f828d9363748d2626fc418a6680a1 (patch)
treed6257cf5a4a202dc70972f5ff8ed7a2da2b54152 /PKGBUILD
parent03538fa959aee566ab18cc8c15899d8aee6dc1b8 (diff)
downloadaur-bb9cef306b1f828d9363748d2626fc418a6680a1.tar.gz
3.2.7-7: fix provides/conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31434f1f0921..8b7e5bfa4d9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,14 @@
: ${_build_git:=false}
unset _pkgtype
+_pkgtype+="-reflink"
[[ "${_build_git::1}" == "t" ]] && _pkgtype+="-git"
## basic info
-_gitname="rsync"
-_pkgname="$_gitname-reflink"
+_pkgname="rsync"
pkgname="$_pkgname${_pkgtype:-}"
pkgver=3.2.7
-pkgrel=6
+pkgrel=7
pkgdesc='A fast and versatile file copying tool for remote and local files - with reflink support'
url='https://github.com/WayneD/rsync'
license=('GPL-3.0-or-later')
@@ -77,7 +77,7 @@ _main_package() {
_main_stable() {
: ${_pkgver:=${pkgver%%.r*}}
- _pkgsrc="$_gitname"
+ _pkgsrc="$_pkgname"
source+=("$_pkgsrc"::"git+$url.git#tag=v${_pkgver:?}")
sha256sums+=('SKIP')
@@ -91,7 +91,7 @@ _main_git() {
provides=("$_pkgname=${pkgver%%.r*}")
conflicts=("$_pkgname")
- _pkgsrc="$_gitname"
+ _pkgsrc="$_pkgname"
source+=("$_pkgsrc"::"git+$url.git")
sha256sums+=('SKIP')