summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Watson2016-11-11 23:10:25 -0500
committerJesse Watson2016-11-11 23:10:25 -0500
commit7f6e6f660412cb88310a92aa9d1e10a4477d67ca (patch)
tree99dea52318d3018a5b22215d740eba07e1473412 /PKGBUILD
downloadaur-7f6e6f660412cb88310a92aa9d1e10a4477d67ca.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42e89c6f4a3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jesse Watson <me@9mmtylenol.me>
+# PKGBUILD: Alex Amadori <tacchinotacchi@gmail.com>
+
+_name=rtbth-dkms
+pkgname=rtbth-dkms-git
+pkgver=3.9.4.4_8aa074e
+pkgrel=1
+pkgdesc="rtbth Kernel module sources for Ralink RT3290 bluetooth, lomiu's solution."
+arch=('i686' 'x86_64')
+url='http://www.mediatek.com/'
+license=('mixed')
+depends=('dkms')
+optdepends=('bluez: Canonical implementation of bluetooth protocol'
+'bluez-utils: Utilities for Bluez')
+conflicts=('rtbth-dkms')
+provides=('rtbth')
+install='rtbth-dkms.install'
+source=('git+https://github.com/loimu/rtbth-dkms.git')
+md5sums=('SKIP')
+
+prepare() {
+cd "${srcdir}/${_name}"
+}
+
+package() {
+cd "${srcdir}/${_name}"
+mkdir -p "${pkgdir}"/usr/bin
+mkdir -p "${pkgdir}"/usr/src
+mkdir -p "${pkgdir}"/etc/modprobe.d/
+cp -r ./ "${pkgdir}/usr/src/${provides}-${pkgver}"
+cp tools/rtbt "${pkgdir}"/usr/bin/rtbt
+cp tools/ralink-bt.conf "${pkgdir}"/etc/modprobe.d/ralink-bt.conf
+}