summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyak2021-08-06 13:16:20 +0300
committerkyak2021-08-06 13:16:20 +0300
commitd45e1fc4dc87d5815089c4a911bec5472f9a2d33 (patch)
tree8d0f881ce3efb371f3c54451df4fed9eb6111b37 /PKGBUILD
downloadaur-d45e1fc4dc87d5815089c4a911bec5472f9a2d33.tar.gz
rteval v3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d288c17d2110
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=rteval
+pkgver=3.2
+pkgrel=1
+pkgdesc="Evaluate performance of realtime Linux kernel on a particular hardware platform"
+arch=('x86_64')
+url="https://wiki.linuxfoundation.org/realtime/documentation/howto/tools/rteval"
+license=('GPL2')
+groups=('realtime')
+depends=('rt-tests' 'python-ethtool' 'python-lxml' 'python-dmidecode')
+source=("git+https://git.kernel.org/pub/scm/utils/rteval/rteval.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${pkgname}"
+ KLOAD="linux-5.7.tar.xz"
+ if [ ! -f "loadsource/$KLOAD" ]; then
+ wget -P loadsource https://www.kernel.org/pub/linux/kernel/v5.x/$KLOAD
+ fi
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}