summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErikas2018-08-20 01:08:01 +0300
committerErikas2018-08-20 01:08:01 +0300
commit2dee5b9fcbdc07ee65980dc6dea4e52e98a8fc25 (patch)
tree9fc1b8e9e35c2ee0782381367ce968c94a864a67 /PKGBUILD
parentf49bef0835d90d8634cd32aa8d2ae6fc286df1b0 (diff)
downloadaur-2dee5b9fcbdc07ee65980dc6dea4e52e98a8fc25.tar.gz
Added support for ARM devices
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8dbc5c28cf5..bb2ed1f6fe88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: zebulon <zeb (at)zebulon(dot)org(dot)uk>
# Contributor: NovaMoon <novamoon1 (at)gmail(dot)com>
+# Contributor: Erikas Rudinskas <erikmnkl (at)gmail(dot)com>
pkgname=rtl8814au-dkms-git
_pkgbase=rtl8814au
pkgver=4.3.21.r34.ga0c4479
pkgrel=1
pkgdesc="RTL8814AU and RTL8813AU chipset driver with firmware v4.3.21"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/zebulon2/rtl8814au"
license=('GPL2')
depends=('dkms' 'bc')
makedepends=('git')
conflicts=("${_pkgbase}")
source=("git+https://github.com/zebulon2/rtl8814au.git"
- 'dkms.conf')
+ 'dkms.conf'
+ 'arm.patch')
sha256sums=('SKIP'
- '36203d04d3ff9e4f117389a24257f608570c418bf4b93fba1b4efd41eb36229a')
+ '36203d04d3ff9e4f117389a24257f608570c418bf4b93fba1b4efd41eb36229a'
+ '2911f6c1285277d0507b2ad7a09c20edd682476be67502db63f63663cac97efb')
pkgver() {
cd ${srcdir}/rtl8814au
@@ -23,7 +26,11 @@ pkgver() {
}
package() {
- cd ${srcdir}/rtl8814au
+ if [ "$CARCH" = "arm" ] || [ "$CARCH" = "armv6h" ] || [ "$CARCH" = "armv7h" ] || [ "$CARCH" = "aarch64" ]; then
+ msg2 "Applying patch for ARM architecture..."
+ patch ${srcdir}/rtl8814au/Makefile -i ${srcdir}/arm.patch
+ fi
+ cd ${srcdir}/rtl8814au
mkdir -p ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp -pr * ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
cp ${srcdir}/dkms.conf ${pkgdir}/usr/src/${_pkgbase}-${pkgver}