summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIyán Méndez Veiga2019-01-29 21:04:49 +0100
committerIyán Méndez Veiga2019-01-29 21:04:49 +0100
commitad1e37868da4c562bd71fcc685aa209155c668ad (patch)
tree04e881a03a675b4c07bfe35b63f249546285ae60 /PKGBUILD
downloadaur-ad1e37868da4c562bd71fcc685aa209155c668ad.tar.gz
Initial commit.
* Renaming package rtl8812au-aircrack-dkms-git * Driver now supports for all Realtek 8811, 8812, 8814 and 8821 chipsets, instead of just the 8812 ones
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03e766f7dc36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+# Contributor: Shaun Ren <shaun DOT ren (at) linux (dOt) com>
+# Contributor: Simon Hanna <simon DOT hanna (at) serve-me (dOt) info>
+
+pkgname=rtl88xxau-aircrack-dkms-git
+_pkgbase=rtl88xxau
+pkgver=r564.87b2f78
+pkgrel=1
+pkgdesc="Aircrack-ng kernel module for Realtek 88XXau network cards (Realtek 8811, 8812, 8814 and 8821 chipsets) with monitor mode and injection support"
+url="https://github.com/aircrack-ng/rtl8812au#branch=v5.2.20"
+license=('GPL')
+arch=('any')
+makedepends=('git')
+depends=('dkms')
+replaces=('rtl8812au-aircrack-dkms-git')
+conflicts=('rtl8812au-dkms-git' 'rtl8812au-inject-dkms-git')
+source=('rtl88xxau::git+https://github.com/aircrack-ng/rtl8812au.git'
+ 'dkms.conf')
+
+sha256sums=('SKIP'
+ 'be0923c2d727f0d64312e879b2887dee04fc5d8c405150a7318a0c9ef08daefc')
+
+pkgver() {
+ cd ${srcdir}/${_pkgbase}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${srcdir}/${_pkgbase}
+ mkdir -p ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
+ cp -pr * ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
+ cp ${srcdir}/dkms.conf ${pkgdir}/usr/src/${_pkgbase}-${pkgver}
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}-dkms/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+}