summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2015-09-28 10:34:18 +0800
committerAllen Zhong2015-09-28 10:34:18 +0800
commit15ded86afd176e70b0debe1cb98d50baff01dc62 (patch)
tree0a14b4a389433b52e158826db32ea34bc5ab5162 /PKGBUILD
parente5bff0675795b9000a6597f5e7cb16c208be5f3f (diff)
downloadaur-15ded86afd176e70b0debe1cb98d50baff01dc62.tar.gz
upgpkg: rtorrent-ipv6 0.9.6-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b10ced34c771..dc3edb729f7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: Allen Zhong <moeallenz@gmail.com>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Daenyth <Daenyth [at] gmail [dot] com>
# Contributor: Jeff Mickey <jeff@archlinux.org>
# Contributor: sh__
@@ -6,12 +7,12 @@
_pkgname=rtorrent
pkgname=rtorrent-ipv6
pkgver=0.9.6
-pkgrel=1
+pkgrel=2
pkgdesc='Ncurses BitTorrent client based on libTorrent, with IPv6 patch'
url='http://rakshasa.github.io/rtorrent/'
license=('GPL')
arch=('i686' 'x86_64')
-depends=('libtorrent=0.13.6' 'curl' 'xmlrpc-c' 'libsigc++')
+depends=('libtorrent-ipv6=0.13.6' 'curl' 'xmlrpc-c' 'libsigc++')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=("$pkgname-$pkgver.tar.gz::https://github.com/rakshasa/${_pkgname}/archive/${pkgver}.tar.gz"
@@ -20,22 +21,23 @@ sha1sums=('27505081254618077c291eb1ee36bfb41f974834'
'bcf7b6b330517b3d577309d52d03395c938d878b')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
patch -uNp1 -i "${srcdir}/${_pkgname}-ipv6.patch"
- sed '/AM_PATH_CPPUNIT/d' -i configure.ac
- ./autogen.sh
+ sed '/AM_PATH_CPPUNIT/d' -i configure.ac
+ ./autogen.sh
- export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- ./configure \
- --prefix=/usr \
- --disable-debug \
- --with-xmlrpc-c \
+ export CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ ./configure \
+ --prefix=/usr \
+ --disable-debug \
+ --with-xmlrpc-c \
+ --enable-ipv6
- make
+ make
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -D doc/rtorrent.rc "${pkgdir}"/usr/share/doc/rtorrent/rtorrent.rc
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -D doc/rtorrent.rc "${pkgdir}"/usr/share/doc/rtorrent/rtorrent.rc
}