summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxsmile2021-07-18 15:59:33 +0200
committerxsmile2021-07-18 15:59:33 +0200
commit3d484e5f21a16b8687968b9cdfec2429ede55525 (patch)
treee8d5d0f374b8dd062620e8a16e2a4508813c37f8 /PKGBUILD
parentb0e1df4e04da2a4bbdc6c89dcf7dd97d3967ea6d (diff)
downloadaur-rtorrent-ps.tar.gz
switch to Clang to avoid GCC compilation issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91de569e15dd..0614d86d0391 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ url='https://github.com/pyroscope/rtorrent-ps'
license=('GPL')
arch=('any')
depends=('curl' 'libtorrent-ps' 'ncurses' 'xmlrpc-c')
+makedepends=('clang')
provides=('rtorrent')
conflicts=('rtorrent')
source=("https://github.com/rakshasa/$_pkgname/archive/v$_pkgver.tar.gz"
@@ -111,6 +112,10 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$_pkgver"
+ # Workaround for GCC compilation issues
+ export CC=/usr/bin/clang
+ export CXX=/usr/bin/clang++
+
./configure \
--prefix=/usr \
--with-xmlrpc-c \