summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2016-12-08 00:04:22 -0500
committerYour Name2016-12-08 00:04:22 -0500
commit342d7c1778c47eb2353263f1b556d0a9e78622c8 (patch)
tree1e9a09e05558d24f2bcc879678b10e07752676df /PKGBUILD
parent9be81720b8306cf83e749ab11797ccbf13365a2b (diff)
downloadaur-342d7c1778c47eb2353263f1b556d0a9e78622c8.tar.gz
remove cppunit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 887f559b7f82..58cb1d6a9495 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ url="https://github.com/pyroscope/rtorrent-ps"
license=('GPL')
arch=('i686' 'x86_64' 'armv7h')
depends=('libtorrent-pyro-git' 'libsigc++' 'ncurses' 'curl' 'xmlrpc-c')
-makedepends=('git' 'cppunit')
+makedepends=('git')
optdepends=('ttf-dejavu: for utf8 glyphs')
conflicts=('rtorrent' 'rtorrent-git')
provides=('rtorrent')
@@ -24,7 +24,12 @@ install='pyroscope.install'
backup=('usr/share/doc/rtorrent/rtorrent.rc.sample')
[[ $_debug = 'n' ]] &&
- _debug='--disable-debug' || options=(!strip)
+ _debug='--disable-debug' ||
+{
+ _debug='--enable-extra-debug'
+ depends+=('cppunit')
+ options=(!strip)
+}
_url="https://raw.githubusercontent.com/pyroscope/rtorrent-ps/master/patches"
source=("git://github.com/rakshasa/rtorrent.git#branch=$_branch"
@@ -91,6 +96,14 @@ build() {
make
}
+check() {
+ [[ ! $_debug = 'n' ]] && {
+ cd "$srcdir/rtorrent"
+ # will fail due to pyroscope patches not being applies to unittests as well
+ make check || return 0
+ }
+}
+
package() {
cd "$srcdir/rtorrent"
make DESTDIR="$pkgdir" install