summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormwberry2015-11-22 14:50:26 -0800
committermwberry2015-11-25 18:58:33 -0800
commit66e6d46064ea488ab852a2dd70402babc82e69ec (patch)
tree9624d67c8aa73dcc2610ab55440ffab22f6d1db0 /PKGBUILD
downloadaur-66e6d46064ea488ab852a2dd70402babc82e69ec.tar.gz
systemd integration for rtorrent
systemd service unit and control program for rtorrent.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8d42e2541a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: mwberry <null [at] example [dot] com>
+pkgname=rtorrent-systemd
+pkgver=0.1
+pkgrel=1
+pkgdesc="systemd integration for rtorrent"
+url="https://wiki.archlinux.org/index.php/User:Mwberry/rtorrent-systemd"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('rtorrent' 'screen' 'bash' 'coreutils')
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=''
+source=()
+md5sums=()
+
+# No build step because all sources are shell scripts
+
+package() {
+
+ mkdir -p "${pkgdir}/usr/lib/systemd/system"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/etc/rtorrent.d"
+
+ cp -a "${pkgdir}/../../rtorrent@.service" "${pkgdir}/usr/lib/systemd/system"
+ cp -a "${pkgdir}/../../rtorrentctl" "${pkgdir}/usr/bin"
+ # There is nothing to copy into the /etc branch,
+ # we just want it to be present for end-users to
+ # populate with system-specific configuration
+
+ # Correct ownership
+ chown -R root:root "${pkgdir}/usr"
+ chown -R root:root "${pkgdir}/etc"
+}
+
+# vim:set ts=2 sw=2 et: