summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVasya Novikov2018-10-29 12:47:46 +0300
committerVasya Novikov2018-10-29 17:26:26 +0300
commit768ee82809e1ff31cf4d86bf34fe4fe1cf46020c (patch)
tree24941fae550f43669ca66a44184d62f375033be8 /PKGBUILD
downloadaur-768ee82809e1ff31cf4d86bf34fe4fe1cf46020c.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ec69b0c2bc3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+
+pkgname=rua
+pkgver=0.5.5
+pkgrel=1
+pkgdesc='convenient jailed AUR helper in rust'
+url='https://github.com/vn971/rua'
+source=("git+https://github.com/vn971/rua.git#tag=$pkgver")
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('bubblewrap')
+optdepends=('rust: to build using the rust'
+ 'rustup: to build using rustup')
+
+# gpg --keyserver keys.gnupg.net --recv-keys AEA6FBA1A5CC9777229EADAB63227A540AC1F12B
+validpgpkeys=('AEA6FBA1A5CC9777229EADAB63227A540AC1F12B')
+sha512sums=('SKIP')
+
+prepare() {
+ git verify-commit HEAD
+}
+
+build () {
+ cd "$srcdir/$pkgname"
+ cargo2 --version >/dev/null || (
+ echo 'cargo not installed. Please install either "rust" or "rustup" pacman package'
+ exit -1
+ )
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "${srcdir}/$pkgname/target/release/rua" "${pkgdir}/usr/bin/rua"
+} \ No newline at end of file