summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVasilii Novikov2021-09-21 09:13:26 +0200
committerVasilii Novikov2021-09-21 09:13:26 +0200
commitce6a1752e487bf7a5ca9186466f98cfb3a23440a (patch)
tree6725fac780963ec7d2bbabd6c1adb6286d70fd73 /PKGBUILD
parent706660dfa80df4e978334328fa7840f8b1b68714 (diff)
downloadaur-ce6a1752e487bf7a5ca9186466f98cfb3a23440a.tar.gz
Add makedepends libseccomp, allow any architecture
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a77429201aea..6696e982b145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@ pkgrel=1
pkgdesc='AUR helper in Rust providing control, review, patch application and safe build options'
url='https://github.com/vn971/rua'
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/vn971/rua/archive/v${pkgver}.tar.gz")
-arch=('x86_64' 'i686')
+arch=('any')
license=('GPL3')
-makedepends=('cargo')
+makedepends=('cargo' 'libseccomp')
depends=('bubblewrap' 'git' 'pacman' 'xz')
optdepends=(
'bubblewrap-suid: version of bubblewrap that works on linux-hardened kernel'
- 'shellcheck: check PKGBUILD scripts, taking care of special variables'
- 'sudo: package installation can be done via sudo, if convenient'
+ 'shellcheck: allows checking PKGBUILD scripts, taking care of special variables'
+ 'sudo: allows package installation via sudo, if desired'
)
#options+=(!strip) # uncomment if you want readable stack traces
@@ -36,4 +36,3 @@ package() {
install -Dm644 target/completions/rua.fish "${pkgdir}/usr/share/fish/completions/rua.fish"
install -Dm644 target/completions/_rua "${pkgdir}/usr/share/zsh/functions/Completion/Linux/_rua"
}
-