summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSven Schneider2013-05-26 19:39:28 +0200
committerSven Schneider2013-05-26 19:39:28 +0200
commit876bb59de8cf0495ea6a6ceabcb07ce3a0107e75 (patch)
treeeb9c5ac8ccdc04354e614ab4b26d50fd820c1f59 /PKGBUILD
downloadaur-876bb59de8cf0495ea6a6ceabcb07ce3a0107e75.tar.gz
ruby-autoproj: added
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d07547e58a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sven Schneider <youremail@domain.com>
+
+_gemname=autoproj
+pkgname=ruby-$_gemname
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="Allows to easily install and maintain software that is under source code form (usually from a version control system)."
+arch=(any)
+url="http://rock-robotics.org/stable/documentation/autoproj/"
+license=('GPL')
+depends=(ruby ruby-autobuild ruby-highline ruby-utilrb)
+makedepends=(rubygems)
+source=(http://gems.rubyforge.org/gems/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+md5sums=(aac2c804bc78dc9bdb74ebc0978494c1)
+
+package() {
+ cd "$srcdir"
+ # _gemdir is defined inside package() because if ruby[gems] is not installed on
+ # the system, makepkg will exit with an error when sourcing the PKGBUILD.
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" \
+ "$_gemname-$pkgver.gem"
+}
+
+# vim:set ts=2 sw=2 et: