summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorColin Arnott2016-09-16 20:21:09 +0000
committerColin Arnott2016-09-16 20:21:09 +0000
commite95e59f8d3f03936f4c8fce1aad21ad50e4fe488 (patch)
treee99f3130bf1486f52e1d96651b4b016755301fb1 /PKGBUILD
downloadaur-e95e59f8d3f03936f4c8fce1aad21ad50e4fe488.tar.gz
init: v0.2.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3695fe6932d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Colin Arnott <colin@urandom.co.uk>
+
+_gemname=azure-signature
+pkgname=ruby-$_gemname
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="The azure-signature library generates storage signatures for Microsoft Azure's cloud platform"
+arch=(any)
+url="http://github.com/djberg96/azure-signature"
+license=('Apache 2.0')
+depends=('ruby' 'ruby-addressable')
+makedepends=('rubygems')
+optdepends=('test-unit')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('368b53678d31ff017eabe22751f636467f185ff0b0ae77008f4c813e21cc4919')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+}