summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2018-06-05 11:24:55 +0200
committerHyacinthe Cartiaux2018-06-05 11:24:55 +0200
commit4a46e912e2f439294435e71c865b26353d2df646 (patch)
treeb0bb1ff0c9f26ac0e7cbff9358e103d7888088db /PKGBUILD
downloadaur-4a46e912e2f439294435e71c865b26353d2df646.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5481ef70da26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux (a) free.fr>
+pkgname=ruby-ddmemoize
+pkgver=1.0.0
+_gemname=${pkgname#ruby-}
+pkgrel=1
+pkgdesc="Adds support for memoizing functions"
+arch=(any)
+url="https://rubygems.org/gems/${_gemname}"
+license=("MIT")
+depends=('ruby' 'ruby-ddmetrics' 'ruby-ref')
+makedepends=(rubygems)
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+sha256sums=('d42cc6aa4800c6e3282918d423accb50470d603280b1cf41a6bf8c061d84d497')
+noextract=($_gemname-$pkgver.gem)
+
+package() {
+ cd "$srcdir"
+
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ HOME="/tmp" GEM_HOME="$_gemdir" GEM_PATH="$_gemdir" gem install \
+ --no-user-install --ignore-dependencies \
+ -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+
+ rm "$pkgdir/$_gemdir/cache/$_gemname-$pkgver.gem"
+}