summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMario Finelli2015-07-06 20:35:33 -0400
committerMario Finelli2015-07-06 20:35:33 -0400
commite98b63161fcbe5e9b826d0e57dc5e0693fbd887d (patch)
tree4f973c52afbdcce25322be378a081e814c8ace00 /PKGBUILD
downloadaur-e98b63161fcbe5e9b826d0e57dc5e0693fbd887d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4820133ab677
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+# Contributor: eagletmt <eagletmt at gmail dot com>
+
+_gemname=oauth
+pkgname=ruby-$_gemname
+pkgver=0.4.7
+pkgrel=3
+pkgdesc='OAuth Core Ruby implementation.'
+arch=("any")
+url='https://rubygems.org/gems/oauth'
+license=('MIT')
+depends=('ruby')
+makedepends=('rubygems')
+source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
+noextract=($_gemname-$pkgver.gem)
+sha256sums=('bca47d77c946af466872269e37e470837858b1305d5143e5a56c50356e02b2cc')
+
+package() {
+ cd "$srcdir"
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --no-user-install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem"
+}