summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2024-04-01 09:55:36 +0200
committerCarl Smedstad2024-04-01 09:55:36 +0200
commit1b0003873bcc65fa03d3af79bb91f4c8063efc5a (patch)
treeb55caf4183d25bdf0491a369c05bb3a0f0ad99c7 /PKGBUILD
parent1394ff0c07ed0d483bcc9f79ccc26f0458507474 (diff)
downloadaur-ruby-prawn.tar.gz
upgpkg: 2.5.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5904e1e2ff0..55f7b899faaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ruby-prawn
_pkgname=${pkgname#ruby-}
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and nimble PDF generator for Ruby"
arch=(any)
url="https://github.com/prawnpdf/prawn"
@@ -15,6 +15,7 @@ license=(
)
depends=(
ruby
+ ruby-matrix
ruby-pdf-core
ruby-ttfunk
)
@@ -34,7 +35,7 @@ prepare() {
cd "$_archive"
# Update gemspec/Gemfile to allow newer version of the dependencies
- sed --in-place --regexp-extended 's|~>|>=|g' "$_pkgname.gemspec"
+ sed -i -E 's|~>|>=|g' "$_pkgname.gemspec"
}
build() {
@@ -98,7 +99,7 @@ package() {
cp -a tmp_install/* "$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.md
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" \
COPYING LICENSE
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" ./*.md
}